xpra icon
Bug tracker and wiki

Opened 5 years ago

Closed 5 years ago

#862 closed defect (invalid)

Error with xpra commands...

Reported by: sezing Owned by: sezing
Priority: major Milestone: 0.16
Component: server Version: 0.15.x
Keywords: Cc:

Description (last modified by Antoine Martin)

hi;

im new in linux and i used xpra in my older server then i changed my provider and instal new server.

whenever i use exit stop info etc commands i take see this error :

root@oynadi:~# xpra stop :1

Warning: running as root
connection failed: [Errno 2] No such file or directory

start atached is works.

thanks in advance

ubuntu 14.04 x64
xpra v0.12.3

Change History (10)

comment:1 Changed 5 years ago by Antoine Martin

Component: androidserver
Description: modified (diff)
Owner: changed from Antoine Martin to sezing

1) don't run as root
2) use an up-to-date version, 0.12.3 is too old
3) please provide more information, as per wiki/ReportingBugs - for example, why you expect "stop" to work on display ":1", the server log file, etc..

comment:2 in reply to:  1 Changed 5 years ago by sezing

Replying to antoine:

1) don't run as root
2) use an up-to-date version, 0.12.3 is too old
3) please provide more information, as per wiki/ReportingBugs - for example, why you expect "stop" to work on display ":1", the server log file, etc..

1) ok i wont
2) how can i update ? what is the ppa: ?
3) i will

thanks a lot

Last edited 5 years ago by Antoine Martin (previous) (diff)

comment:3 Changed 5 years ago by Antoine Martin

2) how can i update ? what is the ppa: ?


See "Download" on the home page: http://xpra.org/

comment:4 in reply to:  3 Changed 5 years ago by sezing

Replying to antoine:

2) how can i update ? what is the ppa: ?


See "Download" on the home page: http://xpra.org/

i saw that page3 but didnt understand anythig which was for ubuntu and how can i find link for it ?

comment:5 Changed 5 years ago by Antoine Martin

Really? I quote: you can install the RPM and Debian repositories by following the repository installation instructions for winswitch. That's the link right there.

comment:6 Changed 5 years ago by Antoine Martin

comment:7 in reply to:  6 Changed 5 years ago by sezing

Replying to antoine:

For trusty, you will land here: http://winswitch.org/downloads/debian-repository.html?dist_select=trusty

xpra = trusty ?

and should i delete xpra and all packages with it ?

i m new in linux sorry for trouble. i m learning :)

comment:8 Changed 5 years ago by sezing

i updated to xpra v0.14.23

thanks :)

this is my rust1.sh file :

#!/bin/bash

xpra start :100
export DISPLAY=:100

cd /home/steam/rust/
screen -A -m -d -S "rust-server" \
wine ./RustDedicated.exe -batchmode

i run this file with my oynadi user

and get this error :

oynadi@oynadi:/home/steam/rust$ ./rust1.sh
xpra main error:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/xpra/scripts/main.py", line 103, in main
    return run_mode(script_file, err, options, args, mode, defaults)
  File "/usr/lib/python2.7/dist-packages/xpra/scripts/main.py", line 760, in run_mode
    return run_server(error_cb, options, mode, script_file, args)
  File "/usr/lib/python2.7/dist-packages/xpra/scripts/server.py", line 834, in run_server
    logfd = open_log_file(log_filename0)
  File "/usr/lib/python2.7/dist-packages/xpra/scripts/server.py", line 417, in open_log_file
    return os.open(logpath, os.O_WRONLY | os.O_CREAT | os.O_TRUNC, o0666)
OSError: [Errno 13] Permission denied: '/home/oynadi/.xpra/:100.log'

when i run with sudo :

oynadi@oynadi:/home/steam/rust$ sudo ./rust1.sh

Warning: running as root
oynadi@oynadi:/home/steam/rust$ Entering daemon mode; any further errors will be reported to:
  /home/oynadi/.xpra/:100.log

i see the process

oynadi@oynadi:/home/steam/rust$ ps 11636
  PID TTY      STAT   TIME COMMAND
11636 ?        Ssl    0:00 Xvfb-for-Xpra-:100 +extension Composite -screen 0 384

when i write for stoping it :

oynadi@oynadi:/home/steam/rust$ sudo xpra stop :100                                            
Warning: running as root
xpra initialization error: connection failed: [Errno 2] No such file or directory
oynadi@oynadi:/home/steam/rust$

i goal is use xpra for my game server console and stop it when i need or restart it

thans a lot for your guiedness :)

comment:9 Changed 5 years ago by Antoine Martin

Personally, I wouldn't start xpra from that script file, I would do:
xpra start :100 --start-child=rust1.sh
And just put your rust stuff in that script file.

You are getting permissions errors because you run things as root.
Nuke the .xpra directory: rm -fr ~/.xpra and start again. Don't use sudo, don't use root.

comment:10 Changed 5 years ago by Antoine Martin

Resolution: invalid
Status: newclosed

not a bug: don't use root, don't mix users.

Note: See TracTickets for help on using tickets.