xpra icon
Bug tracker and wiki

Opened 3 years ago

Closed 3 years ago

#939 closed defect (worksforme)

key mapping issues with shadow server

Reported by: akaWolf Owned by: akaWolf
Priority: major Milestone: 0.16
Component: client Version: trunk
Keywords: Cc:

Description (last modified by Antoine Martin)

I have wrong keyboard layout: local -- us, remote -- us. last string at keyboard: 'zxcvbnm<' instead should have 'zxcvbnm,./'

Attachments (3)

bug-report-939.txt (246.9 KB) - added by Antoine Martin 3 years ago.
bug report tool data
client_log.txt (126.8 KB) - added by akaWolf 3 years ago.
client log with -d keyboard
server_log.txt (104.7 KB) - added by akaWolf 3 years ago.
server log with -d keyboard

Download all attachments as: .zip

Change History (14)

comment:1 Changed 3 years ago by akaWolf

Write, please, if some else info needed.

comment:2 Changed 3 years ago by akaWolf

Server OS: NixOS 15.07pre66213.9d5508d (Dingo)
Client OS: OpenSUSE 13.1

comment:3 Changed 3 years ago by akaWolf

> xmodmap -pke | pastebinit 
http://paste.akawolf.org/view/bVUBS
> xmodmap -pm | pastebinit 
http://paste.akawolf.org/view/9ijfR
> ./xpra/gtk_common/keymap.py | pastebinit 
http://paste.akawolf.org/view/ipshY
> setxkbmap -print
xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us(intl-unicode)+ru:2+inet(evdev)+terminate(ctrl_alt_bksp)+group(rctrl_rshift_toggle)"      };
        xkb_geometry  { include "pc(pc101)"     };
};
> setxkbmap -query
rules:      evdev
model:      pc101
layout:     us,ru
variant:    intl-unicode,
options:    grp:rctrl_rshift_toggle
Last edited 3 years ago by akaWolf (previous) (diff)

comment:4 Changed 3 years ago by Antoine Martin

Owner: set to akaWolf

As per xpra info in the paste, the server was started with:

.xpra-wrapped shadow :0 --daemon=no -d keyboard

Unlike regular servers, shadow servers do not support remapping the keyboard, we do this to ensure we don't end up messing up the keymap of the primary user of the display.
Instead, we try to match the keys to the right ones.

Please provide the server's log file, using -d keyboard should have generated a large log file.

comment:5 Changed 3 years ago by Antoine Martin

Summary: keyboard layoutskey mapping issues with shadow server

(editing bug title)

Changed 3 years ago by Antoine Martin

Attachment: bug-report-939.txt added

bug report tool data

comment:6 Changed 3 years ago by Antoine Martin

Description: modified (diff)
Owner: changed from akaWolf to Antoine Martin
Status: newassigned

(replaced pastebin link with attachement)

comment:7 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to akaWolf
Status: assignednew

As per comment:4, please provide -d keyboard logs.

Changed 3 years ago by akaWolf

Attachment: client_log.txt added

client log with -d keyboard

Changed 3 years ago by akaWolf

Attachment: server_log.txt added

server log with -d keyboard

comment:8 Changed 3 years ago by akaWolf

Owner: changed from akaWolf to Antoine Martin

comment:9 Changed 3 years ago by Antoine Martin

Milestone: 0.16
Status: newassigned

(setting milestone)

comment:10 Changed 3 years ago by Antoine Martin

Owner: changed from Antoine Martin to akaWolf
Status: assignednew

I cannot reproduce this with the latest beta 0.16 packages on Fedora 23.

@akaWolf: can you?

If you can, please include the keyboard debug log output of just the problematic keypress. (the log attached to this ticket has dozens of keypresses in it)

comment:11 Changed 3 years ago by Antoine Martin

Resolution: worksforme
Status: newclosed

Not heard back, closing.

Note: See TracTickets for help on using tickets.