xpra icon
Bug tracker and wiki

Version 1 (modified by Antoine Martin, 4 weeks ago) (diff)

--

Building on Orange PI

These instructions are based on this mailing list post:

XPRA - installation on Orange PI Plus 2E:

  • clean up potentially conflicting packages:
    apt-get purge xpra
    
  • install the development packages (similar to other wiki/Building/Debian distributions):
    apt-get install libx11-dev libxtst-dev libxcomposite-dev libxdamage-dev \
        libxkbfile-dev python-all-dev python-gobject-dev python-gtk2-dev \
        libx264-dev libvpx-dev libswscale-dev libavformat-dev libavcodec-dev \
        xvfb xauth x11-xkb-utils \
        zlib1g zlib1g-dev liblzo2-2 liblzo2-dev
    
  • Some system-supplied Python tools are just too old. Get new ones directly from the world of Python:
    apt-get install python-pip
    pip install --upgrade pip
    pip install lz4
    
  • System version of ffmpeg is too old. Compile new one from source. Note the suggested LDPATH and PIC flag in configuration step. (Found this online at some stage - forgot source - sorry.). Compilation can take a long time.

The build flags used here disable most features and only keep what is actually needed by xpra - you may want to keep more features enabled if you also intend to use the ffmpeg libraries for another purpose:

wget http://ffmpeg.org/releases/ffmpeg-3.3.3.tar.bz2
tar -jxf ffmpeg-3.3.3.tar.bz2
cd ffmpeg-3.3.3
LDPATH=/usr/lib/arm-linux-gnueabihf ./configure \
	--enable-runtime-cpudetect \
	--disable-avdevice \
	--enable-pic \
	--disable-zlib \
	--disable-filters \
	--disable-everything \
	--disable-doc \
	--disable-programs \
	--disable-libxcb \
	--enable-libx264 \
	--enable-libvpx \
	--enable-gpl \
	--enable-protocol=file \
	--enable-decoder=h264 \
	--enable-decoder=hevc \
	--enable-decoder=vp8 \
	--enable-decoder=vp9 \
	--enable-decoder=mpeg4 \
	--enable-encoder=libvpx_vp8 \
	--enable-encoder=libvpx_vp9 \
	--enable-encoder=mpeg4 \
	--enable-encoder=libx264 \
	--enable-encoder=aac \
	--enable-muxer=mp4 \
	--enable-muxer=webm \
	--enable-muxer=matroska \
	--enable-muxer=ogg \
	--enable-demuxer=h264 \
	--enable-demuxer=hevc \
	--enable-demuxer=m4v \
	--enable-demuxer=matroska \
	--enable-demuxer=ogg \
	--enable-shared \
	--enable-debug \
	--disable-stripping \
	--disable-symver \
	--enable-rpath
make
make install
  • to be able to use most of xpra's features, you may also want to install:
    apt-get install python-netifaces dbus-x11 python-dbus python-rencode \
        hicolor-icon-theme python-avahi python-numpy \
        gstreamer1.0-x gstreamer1.0-tools \
        python-pil python-lzo python-setuptools
    
  • build xpra from source as per wiki/Building:
    wget https://www.xpra.org/src/xpra-2.1.1.tar.xz
    unxz xpra-2.1.1.tar.xz
    tar xvf xpra-2.1.1.tar
    cd xpra-2.1.1
    LDPATH=/usr/lib/arm-linux-gnueabihf ./setup.py install